Back to overview
Degraded

eu-central-1 dequeue issues

Aug 24 at 08:18am BST
Affected services
Trigger.dev API

Resolved
Aug 24 at 11:21am BST

This is now resolved.

We're still fully investigating the root cause but there was too much activity with etcd and clean up not happening fast enough. This caused downstream impacts on pods piling up and Kubernetes API rate limits being hit. There were Out Of Memory issues because of this.

Our older Digital Ocean cluster is doing far higher volume that this so we need to determine what configuration is different and making appropriate changes to prevent this happening again.

Created
Aug 24 at 08:18am BST

Our new EU region isn't dequeuing runs, we're working on a fix now.