Back to overview
Degraded
Slower than normal v3 dequeue times
Aug 21 at 11:00am BST
Affected services
Trigger.dev API
Resolved
Aug 22 at 05:03pm BST
v3 dequeue times have been greatly improved and we're now seeing sub-500ms p50 dequeue times (it was previously 10-20s p50 dequeue times). We ended up backporting all of the dequeue performance improvements we made in v4 and even made some improvements that we'll be bringing to v4 soon as well.
Affected services
Created
Aug 21 at 11:00am BST
We are experiencing slower than normal dequeues on v3. We're actively investigating why this is happening. Runs are still executing but they're being pulled from the queue much slower than usual.
Affected services