Back to overview
Degraded
DNS in us-east-1 is degraded
Apr 21, 2026 at 3:40pm UTC
Affected services
Trigger.dev cloud
Trigger.dev OpenTelemetry
Resolved
Apr 21, 2026 at 4:15pm UTC
The issue has been resolved and DNS service is back to normal. We'll continue investigation and share further details in this incident report.
Affected services
Created
Apr 21, 2026 at 3:40pm UTC
We are seeing some DNS resolution issues in us-east-1. OTel spans in the web dashboard are also affected. We are investigating the root cause.
In the meantime, please consider switching to the eu-central-1 region while we investigate.
Affected services