Back to overview
Degraded

Batches are slow to process

Jan 01 at 10:00am GMT
Affected services
Trigger.dev API

Resolved
Jan 01 at 03:10pm GMT

The new batch concurrency processing defaults have brought the processing queue down to zero

Updated
Jan 01 at 02:33pm GMT

The batches are now processing much faster. The issue was the default batch processing concurrency for an organization was too low. Organizations that were already on Hobby or Pro had higher concurrency but newer orgs didn't. This created a backlog.

We've increased the default processing concurrency for each org and will look at the upgrade path for paid customers as well.

We're monitoring the processing – it should get back to near realtime soon.

Created
Jan 01 at 10:00am GMT

There is a backlog in processing batchTrigger and batchTriggerAndWait calls. This means runs are being created slower than normal for these. We're investigating why this is happening