Back to overview
Degraded

Tasks with large payloads or outputs are sometimes failing

Mar 21 at 09:55pm GMT
Affected services
Trigger.dev cloud

Resolved
Mar 21 at 10:48pm GMT

Cloudflare R2 is back online and uploads of large payloads and outputs have resumed. We'll continue to monitor the situation

Updated
Mar 21 at 10:43pm GMT

We've investigated trying to temporarily switch from R2 to AWS S3 but unfortunately we cannot easily do that without breaking backwards compatibility. We're continuing to keep an eye on the Cloudflare Discord for any changes or expected timelines, of which there are none yet.

Updated
Mar 21 at 10:11pm GMT

There is now an incident report on Cloudflare Status:

https://www.cloudflarestatus.com/incidents/v6c7l22vglw5

Updated
Mar 21 at 10:02pm GMT

We've confirmed an ongoing issue with Cloudflare R2 that started approx 20 minutes ago, with this message from their support:

There is an ongoing R2 outage at the moment, expect GET/PUT requests and uploads to intermittently fail.

Created
Mar 21 at 09:55pm GMT

We're currently experiencing an issue with a downstream provider (Cloudflare R2) which we use to store large task payloads and outputs. We're investigating this at the moment and hope to provide more information shortly.