Back to overview
Degraded

V2 runs are processing slowly

Nov 08 at 03:25pm GMT
Affected services
Trigger.dev API

Resolved
Nov 08 at 04:30pm GMT

V2 queues are caught up. Now any queued runs are due to concurrency limits.

V3 was not impacted during the entire period.

We restarted all V2 worker servers and V2 runs started processing again. We are still investigating the underlying cause to prevent this happening again. There were no code changes or deploys during this period and the overall V2 load wasn't unusual.

Updated
Nov 08 at 04:08pm GMT

V2 runs are now dequeuing quickly, it's catching up to normal. We'll update when there are nominal queue times.

Created
Nov 08 at 03:25pm GMT

V2 runs are in the queue for longer than normal, we're investigating what's causing this and working on a fix.