Back to overview
Degraded

Some v3 runs are crashing with triggerAndWait

Aug 20 at 06:00pm BST
Affected services
Trigger.dev cloud
Trigger.dev API

Resolved
Aug 20 at 07:40pm BST

A fix has been deployed and tested. Just confirming that is has fixed all instances of this issue.

Created
Aug 20 at 06:00pm BST

You'll see the status as CRASHED and the error will say:
"Invalid run status for execution: WAITINGTORESUME"

We've diagnosed the issue and are looking to ship a fix quickly